Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Join Date
    Jul 2010
    Location
    Toronto, Ontario
    Posts
    994
    Post Thanks / Like

    Question Cooling fan/shroud noise/vibration

    Hey LXF,

    I've been trying to isolate this problem I have with my cooling fans on my 2010 Challenger SRT 6 Speed.
    A few months ago I've been hearing sounds from one of the fans after engine shut off....after shut off
    one of them made a "wobbly sound" like it was loose or coming off. I figured it was dying....

    This last week after city driving (warm days) the fan assembly started making a louder squeaking sound
    and the whole rad support/fan shroud/grill/nose assembly started shuddering violently; but my temp gauge was still at normal
    levels & the engine kept running. This happened twice in the last 7 days. Otherwise all is ok and no sound/vibration occurs.

    I am taking the chally to the dealership; but don't know what to tell them or how to replicate this intermittent problem.
    I don't want this to cause me to have a roadside breakdown & be stranded.

    Anyone have any input on this issue....any advice welcome...thanks in advance !


  2. #2
    Join Date
    Feb 2012
    Location
    Houston TX
    Posts
    3,785
    Post Thanks / Like
    Replace that fan assembly before it grenades and eats your radiator. $$$

    Your vehicle may (or may not) fall under a recall for the fan blades; earlier SRT's were. The blades themselves would come apart. Problem is, dealer just replaces the blades, not the whole assembly. Results of that job can vary. Mine were out of balance after the replacement blades so I just cashed up myself and replaced the whole fan assembly on my own.

    Richard
    06 Silverado ISS / 06 Silverado SS / 06 300C SRT8
    Thanks HemifeverAZ, jjo thanked for this post
    Likes HemifeverAZ, jjo liked this post

  3. #3
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Looks like this mine let go last week 09 srt 6speed 100,000 miles I recommend the new brushless from dorman see rockauto better improved designed. I’m doing mine with a new Ron Davis radiator


    Sent from my iPhone using Tapatalk
    Thanks someotherguy, jjo thanked for this post

  4. #4
    Join Date
    Feb 2012
    Location
    Houston TX
    Posts
    3,785
    Post Thanks / Like
    Quote Originally Posted by HemifeverAZ View Post
    Looks like this mine let go last week 09 srt 6speed 100,000 miles
    Ouch! Sorry it happened but it's also good confirmation that an 09 can suffer the same fate the earlier years did. I don't know what all years are covered under the recall for the blades.

    Richard
    06 Silverado ISS / 06 Silverado SS / 06 300C SRT8
    Likes HemifeverAZ liked this post

  5. #5
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Quote Originally Posted by someotherguy View Post
    Ouch! Sorry it happened but it's also good confirmation that an 09 can suffer the same fate the earlier years did. I don't know what all years are covered under the recall for the blades.

    Richard
    Doesn’t show up on alldata


    Sent from my iPhone using Tapatalk

  6. #6
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Quote Originally Posted by HemifeverAZ View Post
    Doesn’t show up on alldata


    Sent from my iPhone using Tapatalk
    This week get the new one in an ron returned my unit ready to go


    Sent from my iPhone using Tapatalk
    Likes jjo liked this post

  7. #7
    Join Date
    Jul 2010
    Location
    Toronto, Ontario
    Posts
    994
    Post Thanks / Like

    Thumbs up

    Quote Originally Posted by HemifeverAZ View Post
    Looks like this mine let go last week 09 srt 6speed 100,000 miles I recommend the new brushless from dorman see rockauto better improved designed. I’m doing mine with a new Ron Davis radiator




    Sent from my iPhone using Tapatalk

    So this is your/our OEM Fan assembly after it grenaded ? One fan lost all the blades ?

    Wow...that's dangerous...So u recommend the Dorman from Rock auto, how much did that set u back
    if u don't mind my asking ?

    Thanks again bro !
    Last edited by jjo; 06-26-2019 at 11:49 AM.


  8. #8
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Yes correct

    I did go with the new dorman after talks with Ron Davis he uses the brushless on custom builds which dorman did, if you want to keep no codes an tuning you want to use the oem replace /upgrade
    This fan fits from 09 to 18 srt model that had a 2 fan application
    If you go custom must have tune custom an independednwiring due to the high speed low speed ecm functions


    Sent from my iPhone using Tapatalk

  9. #9
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Quote Originally Posted by jjo View Post
    So this is your/our OEM Fan assembly after it grenaded ? One fan lost all the blades ?

    Wow...that's dangerous...So u recommend the Dorman from Rock auto, how much did that set u back
    if u don't mind my asking ?

    Thanks again bro !

    $252.79
    New improved design

    To get discount an parts at dealer must assemble an cost more highlighted in yellow with my dealer discount was all parts for fan to replace new , not sold as assembly. Also not brushless fans on the oem




    Side note the Dorman brushless is what corvettes have been using for years now



    Sent from my iPhone using Tapatalk
    Likes jjo liked this post

  10. #10
    Join Date
    Jul 2010
    Location
    Toronto, Ontario
    Posts
    994
    Post Thanks / Like

    Talking

    Thanks for all the info HemiFeverAZ...much appreciated !


    Likes HemifeverAZ liked this post

  11. #11
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Quote Originally Posted by jjo View Post
    Thanks for all the info HemiFeverAZ...much appreciated !

    That’s what where here for


    Sent from my iPhone using Tapatalk

  12. #12
    Join Date
    Feb 2012
    Location
    Houston TX
    Posts
    3,785
    Post Thanks / Like
    Quote Originally Posted by HemifeverAZ View Post
    Doesn’t show up on alldata


    Sent from my iPhone using Tapatalk
    I just dug up the info again -

    June 2011 Customer Satisfaction Notification L08
    Engine Cooling Fans
    2006 - 2008 (LX) Dodge Charger, Dodge Magnum, and Chrysler 300
    NOTE: This notification applies to all of the above vehicles equipped with severe duty engine cooling (sales code NMS) or vehicles equipped with (sales code XDL
    or XDK) with “sold to” sales codes and/or are currently registered in warm climate states, built through April 29, 2008 (MDH 042912).

    No mention of Challengers and definitely not any from 09-up. I guess though in your case at 100K miles it's hard to be surprised they let go. It is disappointing that they seem to feel the newer years aren't affected.

    Richard
    06 Silverado ISS / 06 Silverado SS / 06 300C SRT8
    Likes jjo, HemifeverAZ liked this post

  13. #13
    Join Date
    Jul 2010
    Location
    Toronto, Ontario
    Posts
    994
    Post Thanks / Like

    Exclamation Video of the fan/engine shudder....

    So this intermittent problem happened again & I finally got to video it on my iPhone.

    What do you think guys ? Coolant was at proper levels and temp gauge was normal (although it was a hot day in bad traffic) ....

    Pls turn up the sound...

    Fan shudder - YouTube

    Any help/input welcome...pls & thanks !





  14. #14
    Join Date
    Mar 2016
    Location
    N. GA
    Posts
    199
    Post Thanks / Like
    I had a noise that sounded like a fan that was the water pump.
    Although it doesn't sound like a water pump in your video, it only takes a minute to take tension off your belt, grab the water pump pulley and see if it flops around.

    2013 Dodge Charger R/T Plus 362.63HP/389.58TQ
    Thanks jjo thanked for this post
    Likes HemifeverAZ liked this post

  15. #15
    Join Date
    Jun 2019
    Posts
    39
    Post Thanks / Like
    Good old bad bearing syndrome hope while there you did idlers tensioner am belt


    Sent from my iPhone using Tapatalk

Page 1 of 2 12 LastLast

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •