Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24
  1. #16
    Join Date
    Apr 2006
    Posts
    15,130
    Post Thanks / Like
    thanks Pete, going to see if JonW can help me resolve this cause my starscan has not arrived yet.. :(
    I'm only responsible for what I say, not for what you fail to understand.

  2. #17
    Join Date
    Mar 2007
    Posts
    44
    Post Thanks / Like
    I was at the dealer today and when we tried to initialize the TCM is when we got the P1644 code on the starscan. We tried resetting the ECU and the TCM with no luck. If we tried reflashing the TCM would we lose the upgraded programming that came in the Mopar TCM?
    Custom Paint, E&G Grille, Air Ride, 22" Asanti wheels, Nav in Motion, NoESP, 392 Stroker, Twin Turbos, Magnaflow 3" cats and Exhuast, Billet Tech under hood dress up kit

  3. #18
    Join Date
    Apr 2005
    Location
    greasy cardboard box
    Posts
    23,373
    Post Thanks / Like
    Quote Originally Posted by killercustomz View Post
    If we tried reflashing the TCM would we lose the upgraded programming that came in the Mopar TCM?
    if this is a mopar performance TCM, then i have no idea. i would think it would only update to a newer version of the same part number (just guessing).

  4. #19
    Join Date
    Mar 2007
    Posts
    44
    Post Thanks / Like
    It is a Mopar performance TCM. I'm going to get a replacement and see what happens. Thanks for the info.
    Custom Paint, E&G Grille, Air Ride, 22" Asanti wheels, Nav in Motion, NoESP, 392 Stroker, Twin Turbos, Magnaflow 3" cats and Exhuast, Billet Tech under hood dress up kit

  5. #20
    Join Date
    Apr 2006
    Posts
    15,130
    Post Thanks / Like
    keep us posted, as I would like to know..
    I'm only responsible for what I say, not for what you fail to understand.

  6. #21
    Join Date
    Mar 2007
    Posts
    44
    Post Thanks / Like
    Quote Originally Posted by Mr. iNCREDIBLE View Post
    keep us posted, as I would like to know..
    I called the Mopar performance tech line number off the install sheet today and talked to a tech. He said the tcm was fried and if I sent it to them they would reflash it for free. He said they have seen 5 or so of these and most were because the dealer had used the starscan to initialize the tcm. Since the directions do not say not to initialize the performance tcm, like they would with the stock tcm, they will do the reflash at no charge. I will let you know when I get it back next week it that fixes the problem.
    Custom Paint, E&G Grille, Air Ride, 22" Asanti wheels, Nav in Motion, NoESP, 392 Stroker, Twin Turbos, Magnaflow 3" cats and Exhuast, Billet Tech under hood dress up kit

  7. #22
    Join Date
    Sep 2015
    Posts
    14
    Post Thanks / Like
    I am able to fix that issue if you ever need it resolved.

  8. #23
    Join Date
    Jul 2019
    Posts
    8
    Post Thanks / Like
    I have a 2006 Charger R/T. I recently purchased a mopar tcm P5153332 / P5153854ab. I have a Predator with the 91 octane tune. I followed the instructions listed in another posting to install the tcm. the procedure was to take the car back to stock, swap out the tcm, drive the car several miles at different speeds to adapt the module. after adapting the module, reload the tune on the car. i did all of the above without any problem (the car drove great) until i got to the point of reloading the tune. As soon as i loaded the tune back on the car and started it up, and put it in gear, i had nothing. the car would not back up. it would not go forward. even the throttle would not respond. i then took the car back to stock again. with the car back to stock, the car would move in reverse and in forward. i then found that the transmission was in limp and would not shift past second. i scanned the car with the predator and it has only one code P1644. I had to put the original tcm back into the car to be able to drive the vehicle.
    that all happened about a month ago. just to give you as much info as possible, i added a 3.73 Getrag last weekend. i will have to change the gear ratio in the tcm if i can save it. the reason i mention this is i have read another post that recommended loading the 91 tune on the car with the stock tcm and then change the tcm out. doing that would avoid tuning the tcm. with the gear change i just did, i will have to use the predator to change the gear ratio.
    Any suggestions/assistance would be appreciated.

  9. #24
    Join Date
    Jul 2019
    Posts
    8
    Post Thanks / Like
    i sent the tcm in as a core to Karma Racing. they reprogramed the unit and sent it back with their program in it. i sent a note with it indicating that i needed the gear ratio to be 3.73 when they programed it. i got it back and the gear ratio was set and it shifts great. installation was super simple. no tuner needed, no adaptation needed. plug and play. when i changed the gears to 3.73, the lag when the transmission shifted was extremely noticeable. the lag is gone and the shift points are at a much higher rpm. it is a HUGE improvement. i purchased this service through High Horse Performance.



Page 2 of 2 FirstFirst 12

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •