Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2019
    Posts
    24
    Post Thanks / Like

    Gascap notification, P0455 & P0456 keep happening. Related?

    So on my 2008, I keep getting the Check Gascap notification.

    I also intermittently get P0455 (EVAP SYSTEM LARGE LEAK) and P0456 (EVAP SYSTEM SMALL LEAK) which I can reset with my Diablosport Intune.

    It's been driving me insane but I'm not sure where to start trying to find what's causing the issue.

    I'm wondering if these are related issues, and if maybe my car hasn't had the gas tank recall/fix and that might be the cause. Anybody else have suggestions on what to look at?

  2. #2
    Join Date
    Aug 2016
    Location
    Idaho
    Posts
    684
    Post Thanks / Like
    When mine did that, I ended up replacing the evap canister in the rear wheel well. Solved it. No more codes.

    Sent from my SM-N960U using Tapatalk
    2007 R/T, long tubes, off road mids, borla atak exhaust. Inertia cnc big valve heads, inertia raging trojan cam, D1SC procharger 6.1 srt aluminum intake, mopar performance tcm, Trufiber Carbon Fiber SRT8 hood.

  3. #3
    Join Date
    Feb 2018
    Location
    NorCal
    Posts
    216
    Post Thanks / Like



  4. #4
    Join Date
    May 2016
    Posts
    14
    Post Thanks / Like
    Same, it was the evap charcoal canister inside rear wheel well. That was after about 4 new gas caps....

  5. #5
    Join Date
    Aug 2016
    Posts
    110
    Post Thanks / Like
    My daughters 09 SRT4 had this code when we bought it. I'm not sure if it's the same as on the LX cars but there's a electronic box that attaches to the EVAP canister with a large vac hose going to it. This valve must move and hold vacuum during certain conditions. If it doesn't do it 3 times in a row under the same conditions it sets the code. You can replace just that box for like $40. It fixed my daughters car. Probably the same thing on LX cars too.

  6. #6
    Join Date
    Nov 2018
    Posts
    4
    Post Thanks / Like
    got the same problem with my 2007 charger SRT8.
    P0456 P0455 sometimes the lose gas cap on the screen.

    so i got already 3 times on a smoking machine but still cant find the problem.

    first parts i replaced was the
    - gascap
    - EVAP purge solenoid under the hood
    - the white leak detection pump on the carcoal canister in the rear right wheel
    - and the vapor filter attached to it.

    all lines look okay and no smoke visible got the rear seats out and everything looked fine no smoke on the gastank.

    im thinking to replace the carcoal canister that is the last part i didnt replace??

    if you guys can help me out thanks a lot! drives me crazy!

  7. #7
    Join Date
    Nov 2008
    Location
    Northwest, RI
    Posts
    5,668
    Post Thanks / Like
    I did all the easy repairs to my EVAP system. My code ended up being an evap tube on top of the gas tank. Mice chewed thru one of them. I was having the gas tank removed and replaced under warranty when the EVAP tubes were discovered to be chewed. Crazy!
    2005 Magnum RT AWD 344AWHP/358AWTRQ
    FRI Sidewinder Cam, Johan Tune, Edelbrock Headers, JBA Hi-Flo Cats, Magnaflow Catback, 180* T-stat, aFe Stg II CAI, 85mm Throttle Body, SLP 25% UDP, Catch Can, Taylor Shortys, Freak351 Trans Box , Eibach Pro Kit Springs & R1's. Interior, Engine & "M" Emblems by Billet Tech, R/T Emblems, Magnum R/T Grille, Black Heads & Tails, Eyelids

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •