Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2018
    Location
    Pueblo West, Colorado
    Posts
    243
    Post Thanks / Like

    Sloppy shifts when not using Tranzformer

    Hey all!

    I've had a 2005 300c for about a year and a half. I installed a Tranzformer about a week after I got the car, and have been running with it turned on ever since. The other day I swapped out the amp and when I did that, I accidentally pulled the power wire out of the Tranzformer. The car shifts very slowly without the Tranzformer. It's almost like the pump pressure is way too low if that makes sense. I put the wire back in and turned the Tranzformer back on, and shifts are now back to super hard and tight shifting.

    Is this a sign of a failing pump, or possibly a seal or something leaking pressure during shifts? If it's something I can replace/repair to prevent complete failure of the transmission I'd like to do it now before it gets any worse. If it's a sign of the transmission going out, then I'll start watching for a deal on a good used one. The car just turned 190,000.

    Thank you for any suggestions!!

    Sent from my SM-N950U using Scat Pack Forums mobile app

  2. #2
    Join Date
    Mar 2011
    Location
    Colorado Springs Colorado
    Posts
    1,331
    Post Thanks / Like
    You just got used to the firm shifts. The stock shifts are lethargic at best especially the 300 C. After installing the Tranzformer on my 06' 300 SRT I could never drive with it off. The C shifts are even more slow and lethargic and geared towards comfort. If not I have a used Nag been pressure test good to go.

    Sent from my LG-G710 using Scat Pack Forums mobile app
    MODS: AIRAID cai, Heartthrob cat back, Diablo 91 CAI, 180 T-stat, BT Catch can



  3. #3
    Join Date
    Feb 2015
    Posts
    990
    Post Thanks / Like
    Could just be that soft when it's off.

    Try resetting the adaptiveness and turn off your tranzformer and drive around for a bit see if it's any better.

    I don't even notice mine shift if the tranzformer is off, buttery smooth, but I have it set very aggressive, enough that my rear end clunks durring shifts if I have my foot not down enough, or not off throttle.

    Sent from my SM-N900V using Tapatalk
    2005 Brilliant Black 300C
    Qtp dual oval cutouts, LegMaker True V2 CAI
    ZAuto Tranzformer, Diablo Trinity 93 canned tune, Hoosier Dr2

  4. #4
    Join Date
    Nov 2017
    Location
    Florida
    Posts
    200
    Post Thanks / Like
    what does everyone have the transformer set at to shift and what percent scaling?

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •