Results 1 to 5 of 5

Thread: Boost Control

  1. #1
    Join Date
    Oct 2006
    Location
    Cocoa, FL
    Posts
    393
    Post Thanks / Like

    Boost Control

    So, I have T-76 Turbo and Wastegate that are mid mounted on my magnum.
    Wastegate has upper an lower reference ports.

    Spring pressure approx 4-5 psi.
    I am using an electronic boost controller (Innovate SCG-1)
    Solenoid is under hood connected to manifold.
    The line from solenoid to Wastegate is approx 8 feet back to wastegate.
    I have the lower port connected to reference port on outlet of turbo.


    So I am having inconsistent boost always too low.
    WasteGate Duty cycle % always gives me a different number at the gauge.
    I am thinking I need to move solenoid. But hoping for a different answer.
    2005 Silver Magnum R/T-
    Forged 5.7 based 392 built by Arrington
    Rear Mount t76 turbo
    3.06 Getrag, Tranzformer (I love that box)
    1st run on new build
    11.8@117 with only 4.5 psi and a 1.8 60'



  2. #2
    Join Date
    Oct 2006
    Location
    Cocoa, FL
    Posts
    393
    Post Thanks / Like
    2005 Silver Magnum R/T-
    Forged 5.7 based 392 built by Arrington
    Rear Mount t76 turbo
    3.06 Getrag, Tranzformer (I love that box)
    1st run on new build
    11.8@117 with only 4.5 psi and a 1.8 60'

  3. #3
    Join Date
    Mar 2016
    Location
    DE
    Posts
    2,649
    Post Thanks / Like
    What do you mean “wastegate dc always gives different number on the gauge?
    What is your target boost?


    Sent from my iPhone using Scat Pack Forums

  4. #4
    Join Date
    Aug 2008
    Location
    Wichita, Ks.
    Posts
    1,765
    Post Thanks / Like
    If it were me, I would T the reference port off of the turbo and run that to the solenoid instead of off the intake. The pressure will be greatest off of the turbo. You will have pressure drop across inter-cooler, piping and intake. That will give you more pressure and a quicker response to the WG IMO.

    10.33 @ 134 4150# on MH275/17's
    11.55 @ 126 on 275/20 Nittos

  5. #5
    Join Date
    Oct 2006
    Location
    Cocoa, FL
    Posts
    393
    Post Thanks / Like
    So I moved the solenoid to rear of car with wastegate and turbo. I’ll report back when I can test. Roads a bit wet here. Not a good time to test boost.


    Sent from my iPhone using Tapatalk
    2005 Silver Magnum R/T-
    Forged 5.7 based 392 built by Arrington
    Rear Mount t76 turbo
    3.06 Getrag, Tranzformer (I love that box)
    1st run on new build
    11.8@117 with only 4.5 psi and a 1.8 60'

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •