Results 1 to 9 of 9
  1. #1
    Join Date
    Dec 2018
    Posts
    109
    Post Thanks / Like

    Question Procharger with flutter and belt squeal my 300c didn't have before?

    No dash lights or codes when watching on diablo tuner.

    Suddenly have a little less or more sporadic power above 3k, a "flutter" and belt squeal.

    2005 300c awd
    p1 procharger 3.7" pulley getting 5-6psi at 5000rpm
    3200 bfny converter
    tuned by johan

    1. Squeal that I didn’t used to have until last 2-3 weeks. Could just be belt stretching out. I’ve had the kit together for around 3-4K miles and had never heard a belt noise so I don’t know if this is the sound people refer to as procharger belt squeal and I need to go tighter (I’m maxed on tensioner though with current recommended gates belt so would have to go smaller belt I guess). See 4 second video

    2. Loud flutter on heavy acceleration or on letting off throttle after blipping it to 3-4.5K while driving on in park. I don't see bov flutter clearly described as happening when I'm hearing it happen which is why I'm asking you guys! See other videos attached.

    Video links:

    Video_1.MOV - Google Drive
    Video_2.MOV - Google Drive
    Video.MOV - Google Drive

    Any help is appreciated.
    Thank you!
    Currently into Jeep SRT8s (2007 & 2010)

    RIP: Procharged 2005 Chrysler 300c awd, HCA C5Z06, Charger SRT8, C5TT



  2. #2
    Join Date
    Aug 2016
    Location
    Idaho
    Posts
    684
    Post Thanks / Like
    I had the same problem with mine. The belt squeal was the stock tensioner going out. Replaced it with a dayco no slack tensioner and fixed it. And as for the flutter, check the vacuum line going to the relief valve. Sounds like it isn't opening up when you let off.

    Sent from my SM-N960U using Tapatalk
    2007 R/T, long tubes, off road mids, borla atak exhaust. Inertia cnc big valve heads, inertia raging trojan cam, D1SC procharger 6.1 srt aluminum intake, mopar performance tcm, Trufiber Carbon Fiber SRT8 hood.
    Thanks karellan thanked for this post

  3. #3
    Join Date
    Dec 2018
    Posts
    109
    Post Thanks / Like
    Update: kinked vacuum line seems to have been the culprit
    Currently into Jeep SRT8s (2007 & 2010)

    RIP: Procharged 2005 Chrysler 300c awd, HCA C5Z06, Charger SRT8, C5TT
    Likes StrokedRT liked this post

  4. #4
    Join Date
    Aug 2016
    Location
    Idaho
    Posts
    684
    Post Thanks / Like
    Quote Originally Posted by karellan View Post
    Update: kinked vacuum line seems to have been the culprit
    Are you still running the stock procharger relief valve

    Sent from my SM-N960U using Tapatalk
    2007 R/T, long tubes, off road mids, borla atak exhaust. Inertia cnc big valve heads, inertia raging trojan cam, D1SC procharger 6.1 srt aluminum intake, mopar performance tcm, Trufiber Carbon Fiber SRT8 hood.

  5. #5
    Join Date
    Dec 2018
    Posts
    109
    Post Thanks / Like
    Yes, I'm still running the stock one
    Currently into Jeep SRT8s (2007 & 2010)

    RIP: Procharged 2005 Chrysler 300c awd, HCA C5Z06, Charger SRT8, C5TT

  6. #6
    Join Date
    Aug 2016
    Location
    Idaho
    Posts
    684
    Post Thanks / Like
    My vacuum line broke when I was still running the stock one, I felt the flutter bit couldn't really hear it because of the filter. I'm running the upgraded bullet valve now. I can hear the change now. It's louder, but I like it.

    Sent from my SM-N960U using Tapatalk
    2007 R/T, long tubes, off road mids, borla atak exhaust. Inertia cnc big valve heads, inertia raging trojan cam, D1SC procharger 6.1 srt aluminum intake, mopar performance tcm, Trufiber Carbon Fiber SRT8 hood.

  7. #7
    Join Date
    Dec 2018
    Posts
    109
    Post Thanks / Like
    Alright, the followup for any future forum readers. It was indeed totally a vacuum line issue causing majority of the issue. Found a kink my mechanic missed somehow, unkinked, and back to normal.

    Squeak remains but I'm upgrading to a green belt and dayco no slack tensioner this week or next and will confirm if that eliminates or still some prob.

    Thanks for the time and insight guys!
    Currently into Jeep SRT8s (2007 & 2010)

    RIP: Procharged 2005 Chrysler 300c awd, HCA C5Z06, Charger SRT8, C5TT
    Thanks SCOTT57RT thanked for this post

  8. #8
    Join Date
    Jun 2007
    Location
    Jackson, MS
    Posts
    1,634
    Post Thanks / Like
    Quote Originally Posted by karellan View Post
    Alright, the followup for any future forum readers. It was indeed totally a vacuum line issue causing majority of the issue. Found a kink my mechanic missed somehow, unkinked, and back to normal.

    Squeak remains but I'm upgrading to a green belt and dayco no slack tensioner this week or next and will confirm if that eliminates or still some prob.

    Thanks for the time and insight guys!
    Did you see any boost drop off at high RPM? You might plot boost vs RPM to see if it’s bending over due to belt slip. The belt shouldn’t squeak for a stock system.


    2007 Charger R/T, Supercharged
    SCOTT57RT
    2007 RT Charger 5.7L - Black Crystal Pearl
    Mods: DiabloSport Predator - InertiaTuned, MagnaFlow CAT Back Exhaust, JBA High Flow Cats, JBA Headers, 185Tstat, 85mm CNC Throttle Body, 6psi-P1SC Procharger Supercharger, Blown Spartan Cam, 20x9 FR SRT8 Challenger Wheels/Nitto555G2, Mygig, BC Racing Coilovers, Willwood Brakes&Rotors, 3.06 Getrag

  9. #9
    Join Date
    Jan 2016
    Posts
    1,369
    Post Thanks / Like
    I used a Dayco tensioner also. Worked well with used green belt. By the way the tensioner should never be maxed out.

Tags for this Thread

Share This Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •